PDA

View Full Version : Horrible lag while teaming.


Archived Post
09-15-2009, 09:37 PM
For whatever reason, when I group I start to lag really bad. And it gets progressively worse with each additional member. Anyone else experiencing this?

Archived Post
09-15-2009, 10:47 PM
Yup, all the time. I get really bad lag spikes roughly 5-15 seconds long with anything bigger than a 2 man team. I ran through fight club with a full group and was lagged out for most of the mission.

Archived Post
09-16-2009, 12:51 AM
I have yet to experience this with any of my SG mates.

Archived Post
09-16-2009, 01:23 AM
I'm in the same boat, I live in Cyprus and have had minimal problems playing the game until level 30 so far, being in crowded areas the game runs as to be expected, i just did the monster island introduction with other people not being in a group and it was fine, i then went on to do Dr. Destroyers factory and as soon as i was in proximity of my group it became unplayable with unreceived and received packets in the 100's of millions or so. the second i leave the group its back to normal.

I'm just grateful i can enjoy the game so far outside of groups, since some people can't even do that.
I read http://www.gamepath.net/ has been helpful for some but im hesitant to go about using these programs without giving the game a few more weeks to see how things play out.

Your other option is to call your ISP and see if they are throttling your ports.
Champions online uses TCP ports 7000-7599, you can also make sure your firewall and router are open to these.

If you search the other threads such as http://forums.champions-online.com/showthread.php?t=61379 you will see others are much worse off and Cryptic has assured as they are working to resolve the issue, the patches they applied seemed to have helped with some.