PDA

View Full Version : Why can't I see it?


Archived Post
10-08-2010, 02:14 PM
About 3 days ago I loaded up Champions Online for the first time. During the tutorial I could actually see the items my character picked up of the ground (mailboxes, light poles, etc) and tossed at bad guys.

Then there was an update/patch day and now no matter what settings I use I can't see the items I pick up. On top of that, the travel powers i have that have an extra model in them (flying rock, hover disc, etc) no longer display the item I stand on when I fly.

What's the deal? Honestly it was these cool travel power effects that lured me into trying the game in the first place. In all other regards Champions Online is a sorry stand-in for City of Heroes. Now I'll admit that I don't have a 'Super Computer' to run it on, but I'm not running it on a glorified calculator either.

So what's the deal? Why does this game suddenly not deliver? :mad:

Archived Post
10-08-2010, 04:28 PM
Suddenly not deliver? You already said it was a "sorry stand-in" for CoH. You really play just for the travel power effects?

At any rate, I'd update my graphic card drivers and try again. It's not a design feature; you've encountered a bug.

Archived Post
10-08-2010, 05:45 PM
I've already updated the drivers - before AND after the problem occurred.

And yeah, I thought the travel powers would look cool. I also play STO (bt Cryptic/Atari) and it's (IMHO) great.

So yeah, I ask again, What's the deal?

Archived Post
10-08-2010, 06:01 PM
I've already updated the drivers - before AND after the problem occurred.

And yeah, I thought the travel powers would look cool. I also play STO (bt Cryptic/Atari) and it's (IMHO) great.

So yeah, I ask again, What's the deal?

From a tech standpoint, I'd say the game is not the deal and your machine is. I only say that because a ton of people play everyday and don't have a problem.

Under Options at the character screen there is a video tab and you can click the box for advanced settings and see a whole bunch of stuff. I believe I saw something in there regarding FX for powers or some such. I'm no expert, but you might want to browse through those settings and see if something defaulted lower because your system can't handle it.

I know all my setting were set at high or norm from my first install before I cranked things up. Also look at your camera zoom. I only just realized sometimes when I'm zoomed in close, some things like a bench I lifted or a car don't show, but that's mainly so it doesn't block your view. Try zooming out and then you might see things again.

I know it's easy to be frustrated at the game, but I don't think that's the cause.

Archived Post
10-08-2010, 08:20 PM
From a tech standpoint, I'd say the game is not the deal and your machine is. I only say that because a ton of people play everyday and don't have a problem.

Under Options at the character screen there is a video tab and you can click the box for advanced settings and see a whole bunch of stuff. I believe I saw something in there regarding FX for powers or some such. I'm no expert, but you might want to browse through those settings and see if something defaulted lower because your system can't handle it.

I know all my setting were set at high or norm from my first install before I cranked things up. Also look at your camera zoom. I only just realized sometimes when I'm zoomed in close, some things like a bench I lifted or a car don't show, but that's mainly so it doesn't block your view. Try zooming out and then you might see things again.

I know it's easy to be frustrated at the game, but I don't think that's the cause.

I know how to view and alter the video settings. My gripe is that when I first loaded the game I "COULD" see those things. Then the was a patch and then I "COULDN'T" see those things. I doubt the patch altered my hardware.

Oh well, I'm off to uninstall it.

Archived Post
10-08-2010, 08:49 PM
Have you force verified your files in the patcher to make sure nothing got corrupted?

Archived Post
10-09-2010, 12:36 AM
Sounds to me like your system is below the minimum specs for the game, and when something was altered it broke for you. You might want to do a dxdiag and post it so we know what we're dealing with.

Archived Post
10-09-2010, 01:56 AM
About 3 days ago I loaded up Champions Online for the first time. During the tutorial I could actually see the items my character picked up of the ground (mailboxes, light poles, etc) and tossed at bad guys.

Then there was an update/patch day and now no matter what settings I use I can't see the items I pick up. On top of that, the travel powers i have that have an extra model in them (flying rock, hover disc, etc) no longer display the item I stand on when I fly.

What's the deal? Honestly it was these cool travel power effects that lured me into trying the game in the first place. In all other regards Champions Online is a sorry stand-in for City of Heroes. Now I'll admit that I don't have a 'Super Computer' to run it on, but I'm not running it on a glorified calculator either.

So what's the deal? Why does this game suddenly not deliver? :mad:

What? You mean I was supposed to see those objects taken since the start? I never did. :( I thought it was a normal game limitation or something... I do admit, I'D do great screenshots. Even makes it one of the best eye-candy.

Archived Post
10-09-2010, 08:56 AM
About 3 days ago I loaded up Champions Online for the first time. During the tutorial I could actually see the items my character picked up of the ground (mailboxes, light poles, etc) and tossed at bad guys.

Then there was an update/patch day and now no matter what settings I use I can't see the items I pick up. On top of that, the travel powers i have that have an extra model in them (flying rock, hover disc, etc) no longer display the item I stand on when I fly.

What's the deal? Honestly it was these cool travel power effects that lured me into trying the game in the first place. In all other regards Champions Online is a sorry stand-in for City of Heroes. Now I'll admit that I don't have a 'Super Computer' to run it on, but I'm not running it on a glorified calculator either.

So what's the deal? Why does this game suddenly not deliver? :mad:

Could you post a Dxdiag report of you system? How old are the video drivers you're using?

Archived Post
10-09-2010, 09:09 AM
I updated the video drivers the day of installing the game (before) and the day after installing the game.

Honestly, I'm no longer looking for a fix to this problem. Champions Online has been uninstalled from my machine and will likely never clog my memory again. If you enjoy the game then continue to do so, but I didn't so I won't.

Thanks to everyone for trying to help but in my opinion this product isn't worth the effort, which is a shocker for me because Star Trek Online is so good. In the end I spent less than $9 on this little test drive and I got 500 Atari-Points out of it that I can use in STO.

I'm no longer following this thread so no further posts will be forwarded to me.

Archived Post
10-09-2010, 10:16 AM
Jojo don't want no help, Jojo don't get no help...

Jive turkey...

;)

Archived Post
10-10-2010, 04:18 PM
I just upgraded my video card from a 9800gt to a fermi 460gtx and WOW is all I can say. This game was pretty before it is very much so now. To the op, though for all intents and purposes I may be typing to the wall, it does sound more like a user end situation. I prefer my turkey sans the jivelet gravy.